<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /> <script type="text/javascript">var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='Five cornerbacks the Giants could consider';</script> <title>Five cornerbacks the Giants could consider</title><style id="rocket-critical-css">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</style><link rel="preload" href="http://ironbladeonline.com/wp-content/cache/min/1/4bf3e27850db11f087182c3b6d3a0182.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Five cornerbacks the Giants could consider" /><meta property="og:description" content="There may be a new bidder for the Logan Ryan sweepstakes. The Giants may not play for one of their starting cornerbacks again after 2019, when first-round draft pick DeAndre Baker was charged with four counts of armed robbery and four counts of aggravated assault. As of Friday night, his list status had not changed [&hellip;]" /><meta property="og:url" content="http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/" /><meta property="og:site_name" content="Iron Blade Online" /><meta property="article:published_time" content="2020-05-16T09:33:30+00:00" /><meta name="twitter:card" content="summary_large_image" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://ironbladeonline.com/#organization","name":"Ferrum College : Iron Blade Online","url":"http://ironbladeonline.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"http://ironbladeonline.com/#logo","inLanguage":"en-US","url":"http://ironbladeonline.com/wp-content/uploads/2020/05/Iron-Blade-Online.png","width":409,"height":228,"caption":"Ferrum College : Iron Blade Online"},"image":{"@id":"http://ironbladeonline.com/#logo"}},{"@type":"WebSite","@id":"http://ironbladeonline.com/#website","url":"http://ironbladeonline.com/","name":"Iron Blade Online","description":"","publisher":{"@id":"http://ironbladeonline.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"http://ironbladeonline.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#webpage","url":"http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/","name":"Five cornerbacks the Giants could consider","isPartOf":{"@id":"http://ironbladeonline.com/#website"},"datePublished":"2020-05-16T09:33:30+00:00","dateModified":"2020-05-16T09:33:30+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/"]}]},{"@type":"Article","@id":"http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#article","isPartOf":{"@id":"http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#webpage"},"author":{"@id":"http://ironbladeonline.com/#/schema/person/4c4777f5f0b465d5efe92e0f21919080"},"headline":"Five cornerbacks the Giants could consider","datePublished":"2020-05-16T09:33:30+00:00","dateModified":"2020-05-16T09:33:30+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#webpage"},"publisher":{"@id":"http://ironbladeonline.com/#organization"},"articleSection":"Top News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#respond"]}]},{"@type":["Person"],"@id":"http://ironbladeonline.com/#/schema/person/4c4777f5f0b465d5efe92e0f21919080","name":"Patrick R Lanz","image":{"@type":"ImageObject","@id":"http://ironbladeonline.com/#personlogo","inLanguage":"en-US","url":"http://ironbladeonline.com/wp-content/uploads/2020/05/2.jpg","caption":"Patrick R Lanz"},"description":"General troublemaker. Bacon fan. Student. Tv buff. Internet junkie."}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Iron Blade Online &raquo; Feed" href="http://ironbladeonline.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Iron Blade Online &raquo; Comments Feed" href="http://ironbladeonline.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Iron Blade Online &raquo; Five cornerbacks the Giants could consider Comments Feed" href="http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link rel='preload' id='vce-fonts-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9.3' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='vce-style-inline-css' type='text/css'>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</style> <script type='text/javascript' src='http://ironbladeonline.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script>   <link rel='https://api.w.org/' href='http://ironbladeonline.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ironbladeonline.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ironbladeonline.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='http://ironbladeonline.com/?p=916' /><link rel="alternate" type="application/json+oembed" href="http://ironbladeonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F" /><link rel="alternate" type="text/xml+oembed" href="http://ironbladeonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F&#038;format=xml" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-166651492-1', 'auto');
			ga('send', 'pageview');</script> <script data-ad-client="ca-pub-3059805454647315" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-7561420867844318" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-9373527821382765" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-1993645273486601" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-4376846659655258" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-7398690797623797" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-7055430779784404" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-2286843017297526" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-2988081137721490" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-6339419063394600" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-1959342430339023" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-7378220154980429" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-8681597530161456" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-2144735531368922" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-1282998403883329" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-7549848403777038" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-1002222987041100" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-8852359589177633" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-5395246548978360" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script data-ad-client="ca-pub-8512117689471250" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>   <style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="http://ironbladeonline.com/wp-content/uploads/2020/05/cropped-iron-blade-online-icon-32x32.jpg" sizes="32x32" /><link rel="icon" href="http://ironbladeonline.com/wp-content/uploads/2020/05/cropped-iron-blade-online-icon-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="http://ironbladeonline.com/wp-content/uploads/2020/05/cropped-iron-blade-online-icon-180x180.jpg" /><meta name="msapplication-TileImage" content="http://ironbladeonline.com/wp-content/uploads/2020/05/cropped-iron-blade-online-icon-270x270.jpg" /> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-916 single-format-standard wp-embed-responsive vce-sid-right voice-v_2_9_3"><div id="vce-main"><header id="header" class="main-header"><div class="top-header"><div class="container"><div class="vce-wrap-left"><ul id="vce_top_navigation_menu" class="top-nav-menu"><li id="menu-item-498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-498"><a href="http://ironbladeonline.com/">Home</a></li><li id="menu-item-499" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-499"><a href="http://ironbladeonline.com/about-us/">About Us</a></li><li id="menu-item-500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-500"><a href="http://ironbladeonline.com/contact-form/">Contact Form</a></li><li id="menu-item-501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-501"><a href="http://ironbladeonline.com/dmca/">DMCA</a></li><li id="menu-item-503" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-503"><a href="http://ironbladeonline.com/privacy-policy/">Privacy Policy</a></li></ul></div><div class="vce-wrap-right"></div></div></div><div class="container header-1-wrapper header-main-area"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="http://ironbladeonline.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"><source data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Iron Blade Online" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"></picture></a></span><span class="site-description"></span></div></div><div class="header-bottom-wrapper"><div class="container"><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-532" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-532"><a href="http://ironbladeonline.com/">Home</a><li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533 vce-cat-20"><a href="http://ironbladeonline.com/economy/">Economy</a><li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534 vce-cat-24"><a href="http://ironbladeonline.com/entertainment/">entertainment</a><li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535 vce-cat-21"><a href="http://ironbladeonline.com/politics/">Politics</a><li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536 vce-cat-23"><a href="http://ironbladeonline.com/sport/">sport</a><li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537 vce-cat-22"><a href="http://ironbladeonline.com/tech/">Tech</a><li id="menu-item-538" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-538 vce-cat-1"><a href="http://ironbladeonline.com/top-news/">Top News</a><li id="menu-item-539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-539 vce-cat-25"><a href="http://ironbladeonline.com/world/">World</a><li id="menu-item-540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-540"><a href="http://ironbladeonline.com/contact-form/">Contact Form</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form class="vce-search-form" action="http://ironbladeonline.com/" method="get"> <input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /> <button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button></form></li></ul></li></ul></nav></div></div></header><div id="sticky_header" class="header-sticky"><div class="container"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="http://ironbladeonline.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"><source data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Iron Blade Online" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/iron-blade-online.jpg"></picture></a></span></div><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-532"><a href="http://ironbladeonline.com/">Home</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533 vce-cat-20"><a href="http://ironbladeonline.com/economy/">Economy</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534 vce-cat-24"><a href="http://ironbladeonline.com/entertainment/">entertainment</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535 vce-cat-21"><a href="http://ironbladeonline.com/politics/">Politics</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536 vce-cat-23"><a href="http://ironbladeonline.com/sport/">sport</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537 vce-cat-22"><a href="http://ironbladeonline.com/tech/">Tech</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-538 vce-cat-1"><a href="http://ironbladeonline.com/top-news/">Top News</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-539 vce-cat-25"><a href="http://ironbladeonline.com/world/">World</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-540"><a href="http://ironbladeonline.com/contact-form/">Contact Form</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form class="vce-search-form" action="http://ironbladeonline.com/" method="get"> <input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /> <button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button></form></li></ul></li></ul></nav></div></div><div id="main-wrapper"><div id="content" class="container site-content vce-sid-right"><div id="primary" class="vce-main-content"><main id="main" class="main-box main-box-single"><article id="post-916" class="vce-single post-916 post type-post status-publish format-standard hentry category-top-news"><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h1 class="entry-title">Five cornerbacks the Giants could consider</h1><div class="entry-meta"><div class="meta-item date"><span class="updated">5 seconds ago</span></div><div class="meta-item comments"><a href="http://ironbladeonline.com/2020/05/five-cornerbacks-the-giants-could-consider/#respond">Add Comment</a></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="http://ironbladeonline.com/author/vihaan/">Patrick R Lanz</a></span></span></div><div class="meta-item views">0 Views</div></div></header><div class="entry-content"><div><p>There may be a new bidder for the Logan Ryan sweepstakes.</p><p>The Giants may not play for one of their starting cornerbacks again after 2019, when first-round draft pick DeAndre Baker was charged with four counts of armed robbery and four counts of aggravated assault. As of Friday night, his list status had not changed (he had not yet been arrested).</p><p>The cornerback Giants were essential when the offseason began, which is why the bulk of free-agency spending started with James Bradberry opposite Baker. If the Giants return to free agency to replace Baker, they&#8217;ll have $ 16.6 million in cap space, according to NFLPA records, before they need nearly $ 7 million to sign the 2020 draft class.</p><p>Here are the top options available, with their age in parenthesis:</p><p><strong>Logan Ryan (29):</strong> The New Jersey native and Rutgers&#8217; production career comes with 105 tackles, 4.5 bases and four interceptions with the Titans. He spent his first four seasons with the Patriots, where he played special teams under new Giants coach Joe Judge. Ryan says the Titans are not interested in returning to a one-year, $ 10 million deal (not raising). The Jets are part of his market.</p><figure id="attachment_15673331" class="wp-caption alignnone aligncenter"><a target="_blank" class="" href="https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;strip=all" rel="noopener noreferrer"><img alt="Logan Ryan" width="649" height="441" class="size-nypost-large-desktop-uncropped wp-image-15673331 lazyload" data-srcset="https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;w=300 300w, https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;w=640 640w, https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;w=1280 1280w, https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;w=649 649w, https://thenypost.files.wordpress.com/2020/05/logan-ryan.jpg?quality=90&#038;strip=all&#038;w=1298 1298w" data-sizes="(max-width: 640px) 100vw, 649px"/></a><figcaption class="wp-caption-text"><span>Logan Ryan</span><span class="credit">AP</span></figcaption></figure><p><strong>Dre Kirkpatrick (30):</strong> The former first-round draft pick has played 99 games and made 67 starts in eight seasons for the Bengals. He finished last season with a hyperextended knee in an injured reserve and was released in March. He played at the University of Alabama when he was a judge&#8217;s assistant coach.</p><p><strong>Darkwiz Denard (28):</strong> Another former Bengals prospect, Denard had agreed to a three-year, $ 13.5 million deal with the Jaguars in March, but fell. For Pro Football Focus, he was rated the 25th cornerback in the NFL last season.</p><p><b><i>Submit questions to your favorite New York teams to answer in the upcoming mailbag</i></b></p><p><strong>Brandon Carr (33):</strong> How is it to stabilize the uncertainty? Kors never lost a single game in his 12-year NFL career, starting a total of 192 games for the Chiefs, Cowboys and Ravens. The Ravens rejected this option on Carr&#8217;s contract in March, but the Giants&#8217; position could give the former Cowboys a reunion with coach Jerome Henderson.</p><p><strong>B.W. Web (30):</strong> Webb is the definition of a passenger, changing teams after each of the last eight seasons. He played above his contract for the Giants in 2018 and has grown into a leader in the young locker room. The Giants set the Bengals (three years, .5 10.5 million) in the last offseason, but the Web was cut in March.</p></p></div></div><footer class="entry-footer"><div class="meta-tags"></div></footer><div class="vce-share-bar"><ul class="vce-share-items"><div class="meks_ess rounded no-labels solid "><a href="javascript:void(0);" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F&amp;t=Five%20cornerbacks%20the%20Giants%20could%20consider"><span>Facebook</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F&amp;text=Five%20cornerbacks%20the%20Giants%20could%20consider"><span>Twitter</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-googleplus" data-url="https://plus.google.com/share?url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F"><span>Google+</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-pinterest" data-url="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F&amp;media=&amp;description=Five%20cornerbacks%20the%20Giants%20could%20consider"><span>Pinterest</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-linkedin" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fironbladeonline.com%2F2020%2F05%2Ffive-cornerbacks-the-giants-could-consider%2F&amp;title=Five%20cornerbacks%20the%20Giants%20could%20consider"><span>LinkedIn</span></a></div></ul></div></article><nav class="prev-next-nav"><div class="vce-next-link"> <a href="http://ironbladeonline.com/2020/05/jill-scott-wants-us-to-try-patti-labelles-spinach/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20375%20195'%3E%3C/svg%3E" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jill Scott wants us to try Patti LaBelle&#039;s spinach" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589619045_Jill-Scott-wants-us-to-try-Patti-LaBelles-spinach-375x195.jpg" /><noscript><img width="375" height="195" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589619045_Jill-Scott-wants-us-to-try-Patti-LaBelles-spinach-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Jill Scott wants us to try Patti LaBelle&#039;s spinach" /></noscript><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Jill Scott wants us to try Patti LaBelle&#8217;s spinach</span></a></div></nav></main><div class="main-box vce-related-box"><h3 class="main-box-title">You may also like</h3><div class="main-box-inside"><article class="vce-post vce-lay-d post-900 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/prosecutors-for-gregory-mcmichael-say-killing-ahmed-arbury-is-not-just-another-act-of-violent-racism/" title="Prosecutors for Gregory McMichael say killing Ahmed Arbury is &#8216;not just another act of violent racism&#8217;"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Two men arrested in Ahmaud Arbery shooting" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Two men arrested in Ahmaud Arbery shooting" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589617928_Prosecutors-for-Gregory-McMichael-say-killing-Ahmed-Arbury-is-not-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/prosecutors-for-gregory-mcmichael-say-killing-ahmed-arbury-is-not-just-another-act-of-violent-racism/" title="Prosecutors for Gregory McMichael say killing Ahmed Arbury is &#8216;not just another act of violent racism&#8217;">Prosecutors for Gregory McMichael say killing Ahmed...</a></h2></header></article><article class="vce-post vce-lay-d post-895 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/american-believers-see-coronavirus-as-a-sign-from-god/" title="American believers see coronavirus as a sign from God"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="American believers see coronavirus as a sign from God" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="American believers see coronavirus as a sign from God" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589614185_American-believers-see-coronavirus-as-a-sign-from-God-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/american-believers-see-coronavirus-as-a-sign-from-god/" title="American believers see coronavirus as a sign from God">American believers see coronavirus as a sign from God</a></h2></header></article><article class="vce-post vce-lay-d post-890 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/gary-lineker-on-football-return-you-cant-play-football-and-social-distance/" title="Gary Lineker on Football Return: &#8216;You Can&#8217;t Play Football and Social Distance&#8217;"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Gary Lineker on Football Return: &#039;You Can&#039;t Play Football and Social Distance&#039;" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Gary Lineker on Football Return: &#039;You Can&#039;t Play Football and Social Distance&#039;" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611525_Gary-Lineker-on-Football-Return-You-Cant-Play-Football-and-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/gary-lineker-on-football-return-you-cant-play-football-and-social-distance/" title="Gary Lineker on Football Return: &#8216;You Can&#8217;t Play Football and Social Distance&#8217;">Gary Lineker on Football Return: &#8216;You...</a></h2></header></article><article class="vce-post vce-lay-d post-888 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/the-roborace-car-enters-the-street-track-in-marrakech/" title="The &#8216;Roborace&#8217; car enters the street track in Marrakech"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="The &#039;Roborace&#039; car enters the street track in Marrakech" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="The &#039;Roborace&#039; car enters the street track in Marrakech" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589611451_The-Roborace-car-enters-the-street-track-in-Marrakech-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/the-roborace-car-enters-the-street-track-in-marrakech/" title="The &#8216;Roborace&#8217; car enters the street track in Marrakech">The &#8216;Roborace&#8217; car enters the street track...</a></h2></header></article><article class="vce-post vce-lay-d post-878 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/joining-the-same-page-with-the-mets-starters/" title="Joining the same page with the Mets starters"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Joining the same page with the Mets starters" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="Joining the same page with the Mets starters" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/Joining-the-same-page-with-the-Mets-starters-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/joining-the-same-page-with-the-mets-starters/" title="Joining the same page with the Mets starters">Joining the same page with the Mets starters</a></h2></header></article><article class="vce-post vce-lay-d post-876 post type-post status-publish format-standard has-post-thumbnail hentry category-top-news"><div class="meta-image"> <a href="http://ironbladeonline.com/2020/05/jcpenney-bankruptcy-filing-cnn/" title="JCPenney Bankruptcy Filing &#8211; CNN"> <img width="145" height="100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20145%20100'%3E%3C/svg%3E" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="JCPenney Bankruptcy Filing - CNN" data-lazy-srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-634x433.jpg 634w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-145x100.jpg" /><noscript><img width="145" height="100" src="http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="JCPenney Bankruptcy Filing - CNN" srcset="http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-145x100.jpg 145w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-380x260.jpg 380w, http://ironbladeonline.com/wp-content/uploads/2020/05/1589606527_JCPenney-Bankruptcy-Filing-CNN-634x433.jpg 634w" sizes="(max-width: 145px) 100vw, 145px" /></noscript> </a></div><header class="entry-header"> <span class="meta-category"><a href="http://ironbladeonline.com/top-news/" class="category-1">Top News</a></span><h2 class="entry-title"><a href="http://ironbladeonline.com/2020/05/jcpenney-bankruptcy-filing-cnn/" title="JCPenney Bankruptcy Filing &#8211; CNN">JCPenney Bankruptcy Filing &#8211; CNN</a></h2></header></article></div></div><section class="main-box mbt-border-top author-box"><h3 class="main-box-title">About the author</h3><div class="main-box-inside"><div class="data-image"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20112%20112'%3E%3C/svg%3E" width="112" height="112" alt="Patrick R Lanz" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" data-lazy-src="http://ironbladeonline.com/wp-content/uploads/2020/05/2-150x150.jpg" /><noscript><img src="http://ironbladeonline.com/wp-content/uploads/2020/05/2-150x150.jpg" width="112" height="112" alt="Patrick R Lanz" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" /></noscript></div><div class="data-content"><h4 class="author-title">Patrick R Lanz</h4><div class="data-entry-content"><p>General troublemaker. Bacon fan. Student. Tv buff. Internet junkie.</p></div></div></div><div class="vce-content-outside"><div class="data-links"> <a href="http://ironbladeonline.com/author/vihaan/" class="vce-author-link vce-button">View all posts</a></div><div class="vce-author-links"></div></div></section><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/five-cornerbacks-the-giants-could-consider/#respond" style="display:none;">X</a></small></h3><form action="http://ironbladeonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='916' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="35c10ecbc2" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="155"/></p></form></div></div><aside id="sidebar" class="sidebar right"><div id="nav_menu-2" class="widget widget_nav_menu"><h4 class="widget-title">Navigate</h4><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-532"><a href="http://ironbladeonline.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533 vce-cat-20"><a href="http://ironbladeonline.com/economy/">Economy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534 vce-cat-24"><a href="http://ironbladeonline.com/entertainment/">entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535 vce-cat-21"><a href="http://ironbladeonline.com/politics/">Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536 vce-cat-23"><a href="http://ironbladeonline.com/sport/">sport</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537 vce-cat-22"><a href="http://ironbladeonline.com/tech/">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-538 vce-cat-1"><a href="http://ironbladeonline.com/top-news/">Top News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-539 vce-cat-25"><a href="http://ironbladeonline.com/world/">World</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-540"><a href="http://ironbladeonline.com/contact-form/">Contact Form</a></li></ul></div></div><div id="nav_menu-3" class="widget widget_nav_menu"><h4 class="widget-title">Pages</h4><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-498"><a href="http://ironbladeonline.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-499"><a href="http://ironbladeonline.com/about-us/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-500"><a href="http://ironbladeonline.com/contact-form/">Contact Form</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-501"><a href="http://ironbladeonline.com/dmca/">DMCA</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-503"><a href="http://ironbladeonline.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></aside></div><footer id="footer" class="site-footer"><div class="container"><div class="container-fix"><div class="bit-3"></div><div class="bit-3"></div><div class="bit-3"></div></div></div><div class="container-full site-info"><div class="container"><div class="vce-wrap-left"><p>Copyright &copy; 2020. Created by <a href="https://mekshq.com" target="_blank">Meks</a>. Powered by <a href="https://www.wordpress.org" target="_blank">WordPress</a>.</p></div><div class="vce-wrap-right"></div></div></div></footer></div></div> <a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a> <script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "http://ironbladeonline.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "7402ff47a7", post_id : 916 } ); } ); /* ]]> */</script>   <script type='text/javascript'>/* <![CDATA[ */ var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"700","sticky_header_logo":"","logo":"http:\/\/ironbladeonline.com\/wp-content\/uploads\/2020\/05\/iron-blade-online.jpg","logo_retina":"","logo_mobile":"http:\/\/ironbladeonline.com\/wp-content\/uploads\/2020\/05\/iron-blade-online.jpg","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"http:\/\/ironbladeonline.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"","top_bar_more_link":"More"}; /* ]]> */</script>      <script type='text/javascript'>/* <![CDATA[ */ var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var wpreview = {"ajaxurl":"http:\/\/ironbladeonline.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script>     <script type='text/javascript' src='https://stats.wp.com/e-202020.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'48849177',post:'916',tz:'3',srv:'ironbladeonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '48849177', '916' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="http://ironbladeonline.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script src="http://ironbladeonline.com/wp-content/cache/min/1/ede68f97a1b4ea697fe0f659284e4a08.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="http://ironbladeonline.com/wp-content/cache/min/1/4bf3e27850db11f087182c3b6d3a0182.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='vce-fonts-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9.3' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1589621615 -->