    <!doctype html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="https://gmpg.org/xfn/11">

        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='Bulls to sign Goran Dragic';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Bulls to sign Goran Dragic</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /></noscript>
	<meta name="description" content="The bulls It fortifies the depth of the backyard seating with a new addition for the seasoned. Chicago will sign the former All-NBA point guard Goran" />
	<link rel="canonical" href="https://ironbladeonline.com/bulls-to-sign-goran-dragic/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Bulls to sign Goran Dragic" />
	<meta property="og:description" content="The bulls It fortifies the depth of the backyard seating with a new addition for the seasoned. Chicago will sign the former All-NBA point guard Goran" />
	<meta property="og:url" content="https://ironbladeonline.com/bulls-to-sign-goran-dragic/" />
	<meta property="og:site_name" content="Ferrum College : Iron Blade Online" />
	<meta property="article:published_time" content="2022-07-03T21:04:38+00:00" />
	<meta property="og:image" content="https://ironbladeonline.com/wp-content/uploads/2022/07/Bulls-to-sign-Goran-Dragic.jpg" />
	<meta name="author" content="Joy Love" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Joy Love" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ironbladeonline.com/#organization","name":"Ferrum College : Iron Blade Online","url":"https://ironbladeonline.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/#/schema/logo/image/","url":"https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png","contentUrl":"https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png","width":404,"height":166,"caption":"Ferrum College : Iron Blade Online"},"image":{"@id":"https://ironbladeonline.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://ironbladeonline.com/#website","url":"https://ironbladeonline.com/","name":"Ferrum College : Iron Blade Online","description":"Complete Canadian News World","publisher":{"@id":"https://ironbladeonline.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ironbladeonline.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#primaryimage","url":"https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg","contentUrl":"https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg","width":900,"height":499,"caption":"Bulls to sign Goran Dragic"},{"@type":"WebPage","@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#webpage","url":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/","name":"Bulls to sign Goran Dragic","isPartOf":{"@id":"https://ironbladeonline.com/#website"},"primaryImageOfPage":{"@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#primaryimage"},"datePublished":"2022-07-03T21:04:38+00:00","dateModified":"2022-07-03T21:04:38+00:00","description":"The bulls It fortifies the depth of the backyard seating with a new addition for the seasoned. Chicago will sign the former All-NBA point guard Goran","breadcrumb":{"@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ironbladeonline.com/bulls-to-sign-goran-dragic/"]}]},{"@type":"BreadcrumbList","@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Bulls to sign Goran Dragic"}]},{"@type":"Article","@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#article","isPartOf":{"@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#webpage"},"author":{"name":"Joy Love","@id":"https://ironbladeonline.com/#/schema/person/b7f5aaeb9290183eff0773e615dc5e1b"},"headline":"Bulls to sign Goran Dragic","datePublished":"2022-07-03T21:04:38+00:00","dateModified":"2022-07-03T21:04:38+00:00","mainEntityOfPage":{"@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#webpage"},"wordCount":479,"commentCount":0,"publisher":{"@id":"https://ironbladeonline.com/#organization"},"image":{"@id":"https://ironbladeonline.com/bulls-to-sign-goran-dragic/#primaryimage"},"thumbnailUrl":"https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg","articleSection":["sport"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ironbladeonline.com/bulls-to-sign-goran-dragic/#respond"]}]},{"@type":"Person","@id":"https://ironbladeonline.com/#/schema/person/b7f5aaeb9290183eff0773e615dc5e1b","name":"Joy Love","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/e898f11d4cadd2326f299ae15120fd1c?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e898f11d4cadd2326f299ae15120fd1c?s=96&d=mm&r=g","caption":"Joy Love"},"description":"\"Travel aficionado. Infuriatingly humble reader. Incurable internet specialist.\""}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; Feed" href="https://ironbladeonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; Comments Feed" href="https://ironbladeonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; Bulls to sign Goran Dragic Comments Feed" href="https://ironbladeonline.com/bulls-to-sign-goran-dragic/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://ironbladeonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://ironbladeonline.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://ironbladeonline.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://ironbladeonline.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/font-awesome/css/font-awesome.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/slick/css/slick.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/magnific-popup/magnific-popup.css?ver=5.8.1' type='text/css' media='all' />

<link rel='stylesheet' id='newsever-style-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/style.css?ver=5.8.1' type='text/css' media='all' />
<style id='newsever-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://ironbladeonline.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9' type='text/css' media='all' />
<script type='text/javascript' src='https://ironbladeonline.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>

<script type='text/javascript' id='jquery-js-after'>window.addEventListener('DOMContentLoaded', function() {
jQuery(document).ready(function() {
	jQuery(".e6e318cc90dbc9c2555517f53a3e7470").click(function() {
		jQuery.post(
			"https://ironbladeonline.com/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "d388bd162a",
			}, function(response) { }
		);
	});
});
});</script>

<link rel="https://api.w.org/" href="https://ironbladeonline.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ironbladeonline.com/wp-json/wp/v2/posts/12726" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ironbladeonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ironbladeonline.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://ironbladeonline.com/?p=12726' />
<link rel="alternate" type="application/json+oembed" href="https://ironbladeonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fironbladeonline.com%2Fbulls-to-sign-goran-dragic%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ironbladeonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fironbladeonline.com%2Fbulls-to-sign-goran-dragic%2F&#038;format=xml" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com"><meta name="google-site-verification" content="pYhbsMRoxiQzTcVcM75-HmxMvpYFTovWPz7i4YbUYXE" />

<style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://ironbladeonline.com/xmlrpc.php">        <style type="text/css">
                        body .header-style1 .top-header.data-bg:before,
            body .header-style1 .main-header.data-bg:before {
                background: rgba(0, 0, 0, 0);
            }

                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            
            

        </style>
        <style type="text/css">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</style><link rel="icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-150x150.png" sizes="32x32" />
<link rel="icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" />
<meta name="msapplication-TileImage" content="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>    </head>

<body data-rsssl=1 class="post-template-default single single-post postid-12726 single-format-standard wp-custom-logo wp-embed-responsive aft-default-mode aft-hide-comment-count-in-list aft-hide-minutes-read-in-list aft-hide-date-author-in-list default-content-layout content-with-single-sidebar align-content-left">

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>



        <header id="masthead" class="header-style1 header-layout-side">

                <div class="top-header">
        <div class="container-wrapper">
            <div class="top-bar-flex">
                <div class="top-bar-left col-66">

                    
                    <div class="date-bar-left">
                                                    <span class="topbar-date">
                                        July 4, 2022                                    </span>

                                                                    </div>
                                            <div class="af-secondary-menu">
                            <div class="container-wrapper">
                                
                            </div>
                        </div>
                                        </div>

                <div class="top-bar-right col-3">
  						<span class="aft-small-social-menu">
  							  						</span>
                </div>
            </div>
        </div>

    </div>
<div class="main-header  "
     data-background="">
    <div class="container-wrapper">
        <div class="af-container-row af-flex-container">

            
            <div class="col-1 float-l pad">
                <div class="logo-brand">
                    <div class="site-branding">
                        <a href="https://ironbladeonline.com/" class="custom-logo-link" rel="home"><img width="404" height="166" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20404%20166'%3E%3C/svg%3E" class="custom-logo" alt="Ferrum College : Iron Blade Online" data-lazy-srcset="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png 404w, https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-300x123.png 300w" data-lazy-sizes="(max-width: 404px) 100vw, 404px" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" /><noscript><img width="404" height="166" src="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" class="custom-logo" alt="Ferrum College : Iron Blade Online" srcset="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png 404w, https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-300x123.png 300w" sizes="(max-width: 404px) 100vw, 404px" /></noscript></a>                            <p class="site-title font-family-1">
                                <a href="https://ironbladeonline.com/"
                                   rel="home">Ferrum College : Iron Blade Online</a>
                            </p>
                        
                                                    <p class="site-description">Complete Canadian News World</p>
                                            </div>
                </div>
            </div>

            
        </div>
    </div>

</div>
<div class="exclusive-news">
                    <div class="banner-exclusive-posts-wrapper clearfix">

                
                <div class="container-wrapper">
                    <div class="exclusive-posts">
                        <div class="exclusive-now primary-color">
                                                            <span class="exclusive-news-title"> 
                                    Exclusive                                </span>
                                                        <div class="exclusive-now-txt-animation-wrap">
                                <span class="fancy-spinner">
                                    <div class="ring"></div>
                                    <div class="ring"></div>
                                    <div class="dot"></div>
                                </span>
                                <span class="exclusive-texts-wrapper">
                                                                    <span class="exclusive-news-subtitle af-exclusive-animation">
                                        <span>Breaking News</span>
                                    </span>
                                                                </span>
                            </div>
                        </div>
                        <div class="exclusive-slides" dir="ltr">
                                                        <div class='marquee aft-flash-slide left' data-speed='80000'
                                 data-gap='0' data-duplicated='true' data-direction="left">
                                                                    <a href="https://ironbladeonline.com/peter-brook-famous-theater-director-of-scale-and-humanity-dies-at-97/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Peter Brook, famous theater director of Scale and Humanity, dies at 97" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Peter-Brook-famous-theater-director-of-Scale-and-Humanity-dies-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Peter-Brook-famous-theater-director-of-Scale-and-Humanity-dies-150x150.jpg"
                                                 alt="Peter Brook, famous theater director of Scale and Humanity, dies at 97"></noscript>
                                                                            </span>

                                        Peter Brook, famous theater director of Scale and Humanity, dies at 97                                    </a>
                                                                    <a href="https://ironbladeonline.com/james-bardeen-an-expert-in-solving-einsteins-equations-has-died-at-the-age-of-83/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="James Bardeen, an expert in solving Einstein&#8217;s equations, has died at the age of 83" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/James-Bardeen-an-expert-in-solving-Einsteins-equations-has-died-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/James-Bardeen-an-expert-in-solving-Einsteins-equations-has-died-150x150.jpg"
                                                 alt="James Bardeen, an expert in solving Einstein&#8217;s equations, has died at the age of 83"></noscript>
                                                                            </span>

                                        James Bardeen, an expert in solving Einstein&#8217;s equations, has died at the age of 83                                    </a>
                                                                    <a href="https://ironbladeonline.com/bulls-to-sign-goran-dragic/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Bulls to sign Goran Dragic" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-150x150.jpg"
                                                 alt="Bulls to sign Goran Dragic"></noscript>
                                                                            </span>

                                        Bulls to sign Goran Dragic                                    </a>
                                                                    <a href="https://ironbladeonline.com/sony-patent-suggests-ps3-era-surround-compatibility-could-come-to-ps5/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Sony patent suggests PS3 era surround compatibility could come to PS5" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Sony-patent-suggests-PS3-era-surround-compatibility-could-come-to-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Sony-patent-suggests-PS3-era-surround-compatibility-could-come-to-150x150.jpg"
                                                 alt="Sony patent suggests PS3 era surround compatibility could come to PS5"></noscript>
                                                                            </span>

                                        Sony patent suggests PS3 era surround compatibility could come to PS5                                    </a>
                                                                    <a href="https://ironbladeonline.com/alpine-glacier-ripped-off-killing-at-least-6-hikers/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Alpine glacier ripped off, killing at least 6 hikers" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Alpine-glacier-ripped-off-killing-at-least-6-hikers-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Alpine-glacier-ripped-off-killing-at-least-6-hikers-150x150.jpg"
                                                 alt="Alpine glacier ripped off, killing at least 6 hikers"></noscript>
                                                                            </span>

                                        Alpine glacier ripped off, killing at least 6 hikers                                    </a>
                                                            </div>
                                                        </div>
                    </div>
                </div>
            </div>
            <!-- Excluive line END -->
        </div>

            <div class="header-menu-part">
                <div id="main-navigation-bar" class="bottom-bar">
                    <div class="navigation-section-wrapper">
                        <div class="container-wrapper">
                            <div class="header-middle-part">
                                <div class="navigation-container">
                                    <nav class="main-navigation clearfix">
                                                                                    <span class="aft-home-icon">
                                                                                        <a href="https://ironbladeonline.com">
                                            <i class="fa fa-home"
                                               aria-hidden="true"></i>
                                        </a>
                                    </span>
                                                                                <span class="toggle-menu" aria-controls="primary-menu"
                                              aria-expanded="false">
                                                <a href="javascript:void(0)" class="aft-void-menu">
                                        <span class="screen-reader-text">
                                            Primary Menu                                        </span>
                                        <i class="ham"></i>
                                                </a>
                                    </span>
                                        <div class="menu main-menu menu-desktop show-menu-border"><ul id="primary-menu" class="menu"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://ironbladeonline.com">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://ironbladeonline.com/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://ironbladeonline.com/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://ironbladeonline.com/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://ironbladeonline.com/science/">science</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://ironbladeonline.com/tech/">Tech</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-536"><a href="https://ironbladeonline.com/sport/">sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://ironbladeonline.com/entertainment/">entertainment</a></li>
<li id="menu-item-2988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2988"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div>                                    </nav>
                                </div>
                            </div>
                            <div class="header-right-part">
                                <div class="af-search-wrap">
                                    <div class="search-overlay">
                                        <a href="#" title="Search" class="search-icon">
                                            <i class="fa fa-search"></i>
                                        </a>
                                        <div class="af-search-form">
                                            <form role="search" method="get" class="search-form" action="https://ironbladeonline.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                                        </div>
                                    </div>
                                </div>
                                <div class="popular-tag-custom-link">
                                    
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

        </header>

        <!-- end slider-section -->
        
            <div class="container-wrapper">
                    </div>
    
    
        <header class="entry-header pos-rel ">
            <div class="container-wrapper ">
                <div class="read-details af-container-block-wrapper">

                    


                                                <div class="newsever-entry-featured-image-wrap float-l col-2">
                                        <div class="read-img pos-rel">
                            <div class="post-thumbnail full-width-image">
                    <img width="900" height="499" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20900%20499'%3E%3C/svg%3E" class="attachment-newsever-featured size-newsever-featured wp-post-image" alt="Bulls to sign Goran Dragic" data-lazy-srcset="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg 900w, https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-300x166.jpg 300w, https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-768x426.jpg 768w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg" /><noscript><img width="900" height="499" src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg" class="attachment-newsever-featured size-newsever-featured wp-post-image" alt="Bulls to sign Goran Dragic" srcset="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic.jpg 900w, https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-300x166.jpg 300w, https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-768x426.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /></noscript>                </div>
            
                    <span class="aft-image-caption-wrap">

                                            </span>

        </div>
                                </div>
                        
                    <div class="newsever-entry-header-details-wrap float-l col-2">
                            <div class="entry-header-details  af-have-yt-link">
                    <div class="read-categories">
                <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>
            </div>
        
        <h1 class="entry-title">Bulls to sign Goran Dragic</h1>        <div class="post-meta-share-wrapper">
            <div class="post-meta-detail">
                                    <span class="min-read-post-format">
                                                                            </span>
                <span class="entry-meta">
                                        
            <span class="item-metadata posts-author byline">
                    <i class="fa fa-pencil-square-o"></i>
            <a href="https://ironbladeonline.com/author/reyansh/">
                Joy Love            </a>
        </span>
                                            </span>
                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                July 3, 2022            </span>
                        <span class="min-read">2 min read</span>            </div>
                    </div>
        
    </div>
                        </div>


                </div>

            </div>


            
        </header><!-- .entry-header -->

        <!-- end slider-section -->
            
    <div id="content" class="container-wrapper ">
    <div class="af-container-block-wrapper clearfix">
        <div id="primary" class="content-area ">
            <main id="main" class="site-main ">
                                    <article id="post-12726" class="post-12726 post type-post status-publish format-standard has-post-thumbnail hentry category-sport">

                        
                        
                                <div class="entry-content-wrap read-single">
                                                                        

        <div class="entry-content read-details">
            <div>
<p>The <strong>bulls</strong> It fortifies the depth of the backyard seating with a new addition for the seasoned.  Chicago will sign the former All-NBA point guard <strong><a target="_blank" href="https://www.basketball-reference.com/players/d/dragigo01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Goran Dragic</a></strong>    to a one-year contract, according to Jordan Schultz of the Pull Up Podcast (<a target="_blank" href="https://twitter.com/Schultz_Report/status/1543674244021866496" data-wpel-link="external" rel="noopener">Twitter link</a>).</p>
<p>Dragic, most recently with the Nets, will earn $2.9 million, and <a target="_blank" href="https://www.hoopsrumors.com/2022/07/nba-minimum-salaries-for-2022-23.html" data-wpel-link="internal" rel="noopener">Veteran minimum</a>next season, <a target="_blank" href="https://twitter.com/ShamsCharania/status/1543675702947594241" data-wpel-link="external" rel="noopener">Tweets</a> Shams Al-Shaaraniya Athlete.</p>
<p>Dragic, who has an All-Star season and an All-NBA season on his resume, played an important role during the Heat&#8217;s NBA Finals inside the &#8220;bubble&#8221; Orlando campus in 2020. The Slovenian goalkeeper&#8217;s production fell to the ground the following season amid injury problems, and he was&#8230; Finally dealt with it to the Raptors in the signing and trade agreement that landed <strong><a target="_blank" href="https://www.basketball-reference.com/players/l/lowryky01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Kyle Lowry</a></strong>    With the Heat in the 2021 season.</p>
<p>Last year, Dragic made only five appearances for Toronto before he reached an agreement to leave the club as he was looking for a suitable deal.  The 36-year-old was shipped to Tottenham and negotiated a buyout with San Antonio, then taken over with the Nets as a free agent.</p>
<p>Across 16 games with Brooklyn, including six starts, Dragic averaged 7.3 PPG, 4.8 APG and 3.2 RPG, while posting .376/.245/.739 shooting splits.  Although his assist and rebound numbers were in line with his career averages of 4.8 APG and 3.1 RPG, his logging efficiency over 25.5 mpg for Brooklyn was a far cry from his 14-year career average of 13.7 PPG in .460/ .362/.  767 shooting.</p>
<p>Dragic&#8217;s addition marks Chicago&#8217;s fourth free agent agreement in this off-season.  The team agreed to re-sign the All-Star Shooting Guard <strong><strong><a target="_blank" href="https://www.basketball-reference.com/players/l/lavinza01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Zach Lavigne</a></strong></strong>    To the maximum of the bargain, is to bring the deep reserve forward <strong><strong><a target="_blank" href="https://www.basketball-reference.com/players/j/jonesde02.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Derek Jones Jr.</a></strong></strong>and will add a reserve center for the daily worker <strong><a target="_blank" href="https://www.basketball-reference.com/players/d/drumman01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Andre Drummond</a></strong>    to enhance its rebound.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://ironbladeonline.com/cb-patrick-peterson-says-hes-re-signed-with-the-minnesota-vikings/" target="_blank" rel="dofollow" class="u0f96fd6fd3de7a810b39b7969b9cb5e4"><!-- INLINE RELATED POSTS 1/3 //--><style> .u0f96fd6fd3de7a810b39b7969b9cb5e4 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .u0f96fd6fd3de7a810b39b7969b9cb5e4:active, .u0f96fd6fd3de7a810b39b7969b9cb5e4:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u0f96fd6fd3de7a810b39b7969b9cb5e4 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u0f96fd6fd3de7a810b39b7969b9cb5e4 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u0f96fd6fd3de7a810b39b7969b9cb5e4 .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .u0f96fd6fd3de7a810b39b7969b9cb5e4:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">CB Patrick Peterson says he's re-signed with the Minnesota Vikings</span></div></a></div><p>As Yossi Gozlan of HoopsHype notes (<a target="_blank" href="https://twitter.com/YossiGozlan/status/1543676831420690432" data-wpel-link="external" rel="noopener">Via Twitter</a>), thanks to Dragic&#8217;s minimum salary deal, the Bulls are now around $1.7 million less in luxury tax this season, and carry an expected 15 players on guaranteed contracts.  Gozlan adds that Chicago has about $7 million left to use from the mid-level exemption for non-taxpayers.</p>
<p>Any other changes to the Bulls roster are more likely to come by trade than by free agency.  Opening a place on the list now to add another free agent requires trading or assigning an existing bull with a guaranteed salary.  The team also has a $5 million trade exception that will expire after July 7.</p>
<p>If the bulls make a deal, it could involve going deep into their backcourt.  Adds the team to the range of guards that already has <strong><a target="_blank" href="https://www.basketball-reference.com/players/b/balllo01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Lonzo Pool</a></strong>And the <strong><a target="_blank" href="https://www.basketball-reference.com/players/c/carusal01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Alex Caruso</a></strong>And the <strong><a target="_blank" href="https://www.basketball-reference.com/players/d/dosunay01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Ayo Dosunmo</a></strong>And the <strong><a target="_blank" href="https://www.basketball-reference.com/players/w/whiteco01.html?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" rel="nofollow noopener" data-wpel-link="external">Kobe White</a></strong>Although the health of the ball is heading to next season <a target="_blank" href="https://www.hoopsrumors.com/2022/06/lonzo-ball-making-progress-but-status-for-camp-is-uncertain.html" data-wpel-link="internal" rel="noopener">question mark remains</a>.</p>
<p><a target="_blank" href="https://www.nbcsports.com/chicago/bulls/nba-free-agency-bulls-sign-veteran-point-guard-goran-dragic" data-wpel-link="external" rel="noopener">KC Johnson of NBC Sports Chicago</a> Reports indicate that the team expects the current roster to be sound for training camp in the fall, although it acknowledges that the team appears to have a surplus of guards.</p>
</p></div>
<p></p>
<!--CusAds0-->
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100"  height="100" alt="" itemprop="image" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2021/08/43-1.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2021/08/43-1.jpg" width="100"  height="100" alt="" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://ironbladeonline.com/author/reyansh/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Joy Love</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>&#8220;Travel aficionado. Infuriatingly humble reader. Incurable internet specialist.&#8221;</p>
</div></div><div class="clearfix"></div></div></div>                            <div class="post-item-metadata entry-meta">
                                    </div>
                        
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://ironbladeonline.com/ufc-276-results-highlights-israel-adesanya-beats-jared-kannoner-to-retain-middleweight-crown/" rel="prev"><span class="em-post-navigation">Previous</span> UFC 276 results, highlights: Israel Adesanya beats Jared Kannoner to retain middleweight crown</a></div></div>
	</nav>                    </div><!-- .entry-content -->
                                </div>

                        <div class="aft-comment-related-wrap">
                            
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/bulls-to-sign-goran-dragic/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://ironbladeonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='12726' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f4f90ed087" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="113"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

                            
<div class="promotionspace enable-promotionspace">

        <div class="af-reated-posts grid-layout">
                            <h4 class="widget-title header-after1">
                            <span class="header-after">
                                More Stories                            </span>
                </h4>
                        <div class="af-container-row clearfix">
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/UFC-276-results-highlights-Israel-Adesanya-beats-Jared-Kannoner-to-720x475.png">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/UFC-276-results-highlights-Israel-Adesanya-beats-Jared-Kannoner-to-720x475.png"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/UFC-276-results-highlights-Israel-Adesanya-beats-Jared-Kannoner-to-720x475.png"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">3 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/ufc-276-results-highlights-israel-adesanya-beats-jared-kannoner-to-retain-middleweight-crown/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/ufc-276-results-highlights-israel-adesanya-beats-jared-kannoner-to-retain-middleweight-crown/">UFC 276 results, highlights: Israel Adesanya beats Jared Kannoner to retain middleweight crown</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/reyansh/">
                            Joy Love                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/Alexander-Volkanovsky-beats-Max-Holloway-with-unanimous-decision-to-retain-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Alexander-Volkanovsky-beats-Max-Holloway-with-unanimous-decision-to-retain-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Alexander-Volkanovsky-beats-Max-Holloway-with-unanimous-decision-to-retain-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">3 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/alexander-volkanovsky-beats-max-holloway-with-unanimous-decision-to-retain-featherweight-title-at-ufc-276/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/alexander-volkanovsky-beats-max-holloway-with-unanimous-decision-to-retain-featherweight-title-at-ufc-276/">Alexander Volkanovsky beats Max Holloway with unanimous decision to retain featherweight title at UFC 276</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/reyansh/">
                            Joy Love                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/2022-NBA-Free-Agency-Rumors-Live-updates-as-James-Harden-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/2022-NBA-Free-Agency-Rumors-Live-updates-as-James-Harden-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/2022-NBA-Free-Agency-Rumors-Live-updates-as-James-Harden-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/2022-nba-free-agency-rumors-live-updates-as-james-harden-76ers-discuss-new-deal-bulls-push-zach-lavigne/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/2022-nba-free-agency-rumors-live-updates-as-james-harden-76ers-discuss-new-deal-bulls-push-zach-lavigne/">2022 NBA Free Agency Rumors: Live updates as James Harden, 76ers discuss new deal;  Bulls push Zach Lavigne</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 2, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/reyansh/">
                            Joy Love                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                            </div>

    </div>
</div>


                        </div>


                    </article>
                
            </main><!-- #main -->
        </div><!-- #primary -->
        



<div id="secondary" class="sidebar-area aft-sticky-sidebar">
    <div class="theiaStickySidebar">
        <aside class="widget-area color-pad">
            <div id="nav_menu-2" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://ironbladeonline.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://ironbladeonline.com/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://ironbladeonline.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://ironbladeonline.com/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://ironbladeonline.com/science/">science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://ironbladeonline.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-536"><a href="https://ironbladeonline.com/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://ironbladeonline.com/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2988"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div></div><div id="nav_menu-3" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Pages</span></h2><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li id="menu-item-498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-498"><a href="https://ironbladeonline.com/">Home</a></li>
<li id="menu-item-2991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2991"><a href="https://ironbladeonline.com/about-us/">About Us</a></li>
<li id="menu-item-2990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2990"><a href="https://ironbladeonline.com/dmca/">DMCA</a></li>
<li id="menu-item-2989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2989"><a href="https://ironbladeonline.com/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-2992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2992"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div></div>        </aside>
    </div>
</div>    </div>


</div>

<div class="af-main-banner-latest-posts grid-layout">
    <div class="container-wrapper">
    <div class="af-container-block-wrapper pad-20">
            <div class="widget-title-section">
                                    <h4 class="widget-title header-after1">
                            <span class="header-after">
                                You may have missed                            </span>
                    </h4>
                
            </div>
            <div class="af-container-row clearfix">
                                            <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/Peter-Brook-famous-theater-director-of-Scale-and-Humanity-dies-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Peter-Brook-famous-theater-director-of-Scale-and-Humanity-dies-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Peter-Brook-famous-theater-director-of-Scale-and-Humanity-dies-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/peter-brook-famous-theater-director-of-scale-and-humanity-dies-at-97/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/entertainment/" alt="View all posts in entertainment"> 
                                 entertainment
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/peter-brook-famous-theater-director-of-scale-and-humanity-dies-at-97/">Peter Brook, famous theater director of Scale and Humanity, dies at 97</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/muhammad/">
                            Roxanne Bacchus                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/James-Bardeen-an-expert-in-solving-Einsteins-equations-has-died-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/James-Bardeen-an-expert-in-solving-Einsteins-equations-has-died-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/James-Bardeen-an-expert-in-solving-Einsteins-equations-has-died-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">5 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/james-bardeen-an-expert-in-solving-einsteins-equations-has-died-at-the-age-of-83/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/james-bardeen-an-expert-in-solving-einsteins-equations-has-died-at-the-age-of-83/">James Bardeen, an expert in solving Einstein&#8217;s equations, has died at the age of 83</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/vihaan/">
                            Cheryl Riley                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/1656882280_Bulls-to-sign-Goran-Dragic-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/bulls-to-sign-goran-dragic/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/bulls-to-sign-goran-dragic/">Bulls to sign Goran Dragic</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/reyansh/">
                            Joy Love                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/07/Sony-patent-suggests-PS3-era-surround-compatibility-could-come-to-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/07/Sony-patent-suggests-PS3-era-surround-compatibility-could-come-to-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/07/Sony-patent-suggests-PS3-era-surround-compatibility-could-come-to-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/sony-patent-suggests-ps3-era-surround-compatibility-could-come-to-ps5/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/sony-patent-suggests-ps3-era-surround-compatibility-could-come-to-ps5/">Sony patent suggests PS3 era surround compatibility could come to PS5</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    July 3, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/frosty-dirac/">
                            Len Houle                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                        </div>
    </div>
    </div>
</div>

<footer class="site-footer">
        
                <div class="site-info">
        <div class="container-wrapper">
            <div class="af-container-row">
                <div class="col-1 color-pad">
                                                                Copyright &copy; All rights reserved.                                                                                    <span class="sep"> | </span>
                        <a href="https://afthemes.com/products/newsever">Newsever</a> by AF themes.                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>













<script type='text/javascript' id='newsever-pagination-js-js-extra'>
/* <![CDATA[ */
var AFurl = {"nonce":"7d89fcd488","ajaxurl":"https:\/\/ironbladeonline.com\/wp-admin\/admin-ajax.php","dir":"left"};
/* ]]> */
</script>




<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/ironbladeonline.com\/wp-json\/","fifu_nonce":"b315fc727a"};
/* ]]> */
</script>

<script src='https://stats.wp.com/e-202227.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'196518127',post:'12726',tz:'2',srv:'ironbladeonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '196518127', '12726' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ironbladeonline.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://ironbladeonline.com/wp-content/cache/min/1/7436cfaac6d475cbbc0b651722e34f8e.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->