    <!doctype html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="https://gmpg.org/xfn/11">

        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v19.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /></noscript>
	<meta name="description" content="The full lineup is as follows: PS Plus Extra PS Plus Premium It&#039;s been a great month this time around, as the PS Plus Extra has once again brought the" />
	<link rel="canonical" href="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week" />
	<meta property="og:description" content="The full lineup is as follows: PS Plus Extra PS Plus Premium It&#039;s been a great month this time around, as the PS Plus Extra has once again brought the" />
	<meta property="og:url" content="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/" />
	<meta property="og:site_name" content="Ferrum College : Iron Blade Online" />
	<meta property="article:published_time" content="2022-12-14T18:21:39+00:00" />
	<meta property="og:image" content="https://ironbladeonline.com/wp-content/uploads/2022/12/22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg" />
	<meta name="author" content="Len Houle" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Len Houle" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://ironbladeonline.com/#organization","name":"Ferrum College : Iron Blade Online","url":"https://ironbladeonline.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/#/schema/logo/image/","url":"https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png","contentUrl":"https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png","width":404,"height":166,"caption":"Ferrum College : Iron Blade Online"},"image":{"@id":"https://ironbladeonline.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://ironbladeonline.com/#website","url":"https://ironbladeonline.com/","name":"Ferrum College : Iron Blade Online","description":"Complete Canadian News World","publisher":{"@id":"https://ironbladeonline.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://ironbladeonline.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#primaryimage","url":"https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg","contentUrl":"https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg","width":1280,"height":720,"caption":"22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week"},{"@type":"WebPage","@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/","url":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/","name":"22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week","isPartOf":{"@id":"https://ironbladeonline.com/#website"},"primaryImageOfPage":{"@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#primaryimage"},"datePublished":"2022-12-14T18:21:39+00:00","dateModified":"2022-12-14T18:21:39+00:00","description":"The full lineup is as follows: PS Plus Extra PS Plus Premium It's been a great month this time around, as the PS Plus Extra has once again brought the","breadcrumb":{"@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/"]}]},{"@type":"BreadcrumbList","@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week"}]},{"@type":"Article","@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#article","isPartOf":{"@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/"},"author":{"name":"Len Houle","@id":"https://ironbladeonline.com/#/schema/person/b63e50e3a13ed5a31fd4477ac4771764"},"headline":"22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week","datePublished":"2022-12-14T18:21:39+00:00","dateModified":"2022-12-14T18:21:39+00:00","mainEntityOfPage":{"@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/"},"wordCount":420,"commentCount":0,"publisher":{"@id":"https://ironbladeonline.com/#organization"},"image":{"@id":"https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#primaryimage"},"thumbnailUrl":"https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg","articleSection":["Tech"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#respond"]}]},{"@type":"Person","@id":"https://ironbladeonline.com/#/schema/person/b63e50e3a13ed5a31fd4477ac4771764","name":"Len Houle","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://ironbladeonline.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/a72c99a1f21fb768b2f3aaf22239b102?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/a72c99a1f21fb768b2f3aaf22239b102?s=96&d=mm&r=g","caption":"Len Houle"},"description":"\"Hipster-friendly explorer. Award-winning coffee fanatic. Analyst. Problem solver. Troublemaker.\""}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; Feed" href="https://ironbladeonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; Comments Feed" href="https://ironbladeonline.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferrum College : Iron Blade Online &raquo; 22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week Comments Feed" href="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://ironbladeonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://ironbladeonline.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://ironbladeonline.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://ironbladeonline.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/font-awesome/css/font-awesome.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/slick/css/slick.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/assets/magnific-popup/magnific-popup.css?ver=5.8.1' type='text/css' media='all' />

<link rel='stylesheet' id='newsever-style-css'  href='https://ironbladeonline.com/wp-content/themes/newsever-pro/style.css?ver=5.8.1' type='text/css' media='all' />
<style id='newsever-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://ironbladeonline.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9' type='text/css' media='all' />
<script type='text/javascript' src='https://ironbladeonline.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>

<script type='text/javascript' id='jquery-js-after'>window.addEventListener('DOMContentLoaded', function() {
jQuery(document).ready(function() {
	jQuery(".e6e318cc90dbc9c2555517f53a3e7470").click(function() {
		jQuery.post(
			"https://ironbladeonline.com/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "6a920be341",
			}, function(response) { }
		);
	});
});
});</script>

<link rel="https://api.w.org/" href="https://ironbladeonline.com/wp-json/" /><link rel="alternate" type="application/json" href="https://ironbladeonline.com/wp-json/wp/v2/posts/22938" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://ironbladeonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://ironbladeonline.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://ironbladeonline.com/?p=22938' />
<link rel="alternate" type="application/json+oembed" href="https://ironbladeonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fironbladeonline.com%2F22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://ironbladeonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fironbladeonline.com%2F22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week%2F&#038;format=xml" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com"><meta name="google-site-verification" content="pYhbsMRoxiQzTcVcM75-HmxMvpYFTovWPz7i4YbUYXE" />

<style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://ironbladeonline.com/xmlrpc.php">        <style type="text/css">
                        body .header-style1 .top-header.data-bg:before,
            body .header-style1 .main-header.data-bg:before {
                background: rgba(0, 0, 0, 0);
            }

                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            
            

        </style>
        <style type="text/css">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</style><link rel="icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-150x150.png" sizes="32x32" />
<link rel="icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" />
<meta name="msapplication-TileImage" content="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>    </head>

<body data-rsssl=1 class="post-template-default single single-post postid-22938 single-format-standard wp-custom-logo wp-embed-responsive aft-default-mode aft-hide-comment-count-in-list aft-hide-minutes-read-in-list aft-hide-date-author-in-list default-content-layout content-with-single-sidebar align-content-left">

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>



        <header id="masthead" class="header-style1 header-layout-side">

                <div class="top-header">
        <div class="container-wrapper">
            <div class="top-bar-flex">
                <div class="top-bar-left col-66">

                    
                    <div class="date-bar-left">
                                                    <span class="topbar-date">
                                        December 14, 2022                                    </span>

                                                                    </div>
                                            <div class="af-secondary-menu">
                            <div class="container-wrapper">
                                
                            </div>
                        </div>
                                        </div>

                <div class="top-bar-right col-3">
  						<span class="aft-small-social-menu">
  							  						</span>
                </div>
            </div>
        </div>

    </div>
<div class="main-header  "
     data-background="">
    <div class="container-wrapper">
        <div class="af-container-row af-flex-container">

            
            <div class="col-1 float-l pad">
                <div class="logo-brand">
                    <div class="site-branding">
                        <a href="https://ironbladeonline.com/" class="custom-logo-link" rel="home"><img width="404" height="166" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20404%20166'%3E%3C/svg%3E" class="custom-logo" alt="Ferrum College : Iron Blade Online" data-lazy-srcset="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png 404w, https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-300x123.png 300w" data-lazy-sizes="(max-width: 404px) 100vw, 404px" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" /><noscript><img width="404" height="166" src="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png" class="custom-logo" alt="Ferrum College : Iron Blade Online" srcset="https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE.png 404w, https://ironbladeonline.com/wp-content/uploads/2021/06/IRON-BLADE-ONLINE-300x123.png 300w" sizes="(max-width: 404px) 100vw, 404px" /></noscript></a>                            <p class="site-title font-family-1">
                                <a href="https://ironbladeonline.com/"
                                   rel="home">Ferrum College : Iron Blade Online</a>
                            </p>
                        
                                                    <p class="site-description">Complete Canadian News World</p>
                                            </div>
                </div>
            </div>

            
        </div>
    </div>

</div>
<div class="exclusive-news">
                    <div class="banner-exclusive-posts-wrapper clearfix">

                
                <div class="container-wrapper">
                    <div class="exclusive-posts">
                        <div class="exclusive-now primary-color">
                                                            <span class="exclusive-news-title"> 
                                    Exclusive                                </span>
                                                        <div class="exclusive-now-txt-animation-wrap">
                                <span class="fancy-spinner">
                                    <div class="ring"></div>
                                    <div class="ring"></div>
                                    <div class="dot"></div>
                                </span>
                                <span class="exclusive-texts-wrapper">
                                                                    <span class="exclusive-news-subtitle af-exclusive-animation">
                                        <span>Breaking News</span>
                                    </span>
                                                                </span>
                            </div>
                        </div>
                        <div class="exclusive-slides" dir="ltr">
                                                        <div class='marquee aft-flash-slide left' data-speed='80000'
                                 data-gap='0' data-duplicated='true' data-direction="left">
                                                                    <a href="https://ironbladeonline.com/patty-jenkins-breaks-the-silence-in-wonder-woman-3/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Patty Jenkins breaks the silence in Wonder Woman 3" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/Patty-Jenkins-breaks-the-silence-in-Wonder-Woman-3-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/Patty-Jenkins-breaks-the-silence-in-Wonder-Woman-3-150x150.jpg"
                                                 alt="Patty Jenkins breaks the silence in Wonder Woman 3"></noscript>
                                                                            </span>

                                        Patty Jenkins breaks the silence in Wonder Woman 3                                    </a>
                                                                    <a href="https://ironbladeonline.com/the-mars-rover-captures-the-first-sound-of-a-dust-devil-on-the-red-planet/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="The Mars rover captures the first sound of a dust devil on the Red Planet" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mars-rover-captures-the-first-sound-of-a-dust-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mars-rover-captures-the-first-sound-of-a-dust-150x150.jpg"
                                                 alt="The Mars rover captures the first sound of a dust devil on the Red Planet"></noscript>
                                                                            </span>

                                        The Mars rover captures the first sound of a dust devil on the Red Planet                                    </a>
                                                                    <a href="https://ironbladeonline.com/jets-robert-salih-zach-wilson-is-the-lions-no-2-qb/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Jets&#8217; Robert Salih &#8211; Zach Wilson is the Lions&#8217; No. 2 QB" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/Jets-Robert-Salih-Zach-Wilson-is-the-Lions-No-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/Jets-Robert-Salih-Zach-Wilson-is-the-Lions-No-150x150.jpg"
                                                 alt="Jets&#8217; Robert Salih &#8211; Zach Wilson is the Lions&#8217; No. 2 QB"></noscript>
                                                                            </span>

                                        Jets&#8217; Robert Salih &#8211; Zach Wilson is the Lions&#8217; No. 2 QB                                    </a>
                                                                    <a href="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-150x150.jpg"
                                                 alt="22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week"></noscript>
                                                                            </span>

                                        22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week                                    </a>
                                                                    <a href="https://ironbladeonline.com/a-turkish-court-sentences-erdogans-rival-to-prison-with-a-political-ban/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="A Turkish court sentences Erdogan&#8217;s rival to prison with a political ban" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671041869_A-Turkish-court-sentences-Erdogans-rival-to-prison-with-a-150x150.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671041869_A-Turkish-court-sentences-Erdogans-rival-to-prison-with-a-150x150.jpg"
                                                 alt="A Turkish court sentences Erdogan&#8217;s rival to prison with a political ban"></noscript>
                                                                            </span>

                                        A Turkish court sentences Erdogan&#8217;s rival to prison with a political ban                                    </a>
                                                            </div>
                                                        </div>
                    </div>
                </div>
            </div>
            <!-- Excluive line END -->
        </div>

            <div class="header-menu-part">
                <div id="main-navigation-bar" class="bottom-bar">
                    <div class="navigation-section-wrapper">
                        <div class="container-wrapper">
                            <div class="header-middle-part">
                                <div class="navigation-container">
                                    <nav class="main-navigation clearfix">
                                                                                    <span class="aft-home-icon">
                                                                                        <a href="https://ironbladeonline.com">
                                            <i class="fa fa-home"
                                               aria-hidden="true"></i>
                                        </a>
                                    </span>
                                                                                <span class="toggle-menu" aria-controls="primary-menu"
                                              aria-expanded="false">
                                                <a href="javascript:void(0)" class="aft-void-menu">
                                        <span class="screen-reader-text">
                                            Primary Menu                                        </span>
                                        <i class="ham"></i>
                                                </a>
                                    </span>
                                        <div class="menu main-menu menu-desktop show-menu-border"><ul id="primary-menu" class="menu"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://ironbladeonline.com">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://ironbladeonline.com/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://ironbladeonline.com/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://ironbladeonline.com/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://ironbladeonline.com/science/">science</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-535"><a href="https://ironbladeonline.com/tech/">Tech</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://ironbladeonline.com/sport/">sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://ironbladeonline.com/entertainment/">entertainment</a></li>
<li id="menu-item-2988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2988"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div>                                    </nav>
                                </div>
                            </div>
                            <div class="header-right-part">
                                <div class="af-search-wrap">
                                    <div class="search-overlay">
                                        <a href="#" title="Search" class="search-icon">
                                            <i class="fa fa-search"></i>
                                        </a>
                                        <div class="af-search-form">
                                            <form role="search" method="get" class="search-form" action="https://ironbladeonline.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                                        </div>
                                    </div>
                                </div>
                                <div class="popular-tag-custom-link">
                                    
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

        </header>

        <!-- end slider-section -->
        
            <div class="container-wrapper">
                    </div>
    
    
        <header class="entry-header pos-rel ">
            <div class="container-wrapper ">
                <div class="read-details af-container-block-wrapper">

                    


                                                <div class="newsever-entry-featured-image-wrap float-l col-2">
                                        <div class="read-img pos-rel">
                            <div class="post-thumbnail full-width-image">
                    <img width="1024" height="576" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20576'%3E%3C/svg%3E" class="attachment-newsever-featured size-newsever-featured wp-post-image" alt="22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week" data-lazy-srcset="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-1024x576.jpg 1024w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-300x169.jpg 300w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-768x432.jpg 768w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg 1280w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-1024x576.jpg" /><noscript><img width="1024" height="576" src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-1024x576.jpg" class="attachment-newsever-featured size-newsever-featured wp-post-image" alt="22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week" srcset="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-1024x576.jpg 1024w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-300x169.jpg 300w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-768x432.jpg 768w, https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript>                </div>
            
                    <span class="aft-image-caption-wrap">

                                            </span>

        </div>
                                </div>
                        
                    <div class="newsever-entry-header-details-wrap float-l col-2">
                            <div class="entry-header-details  af-have-yt-link">
                    <div class="read-categories">
                <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>
            </div>
        
        <h1 class="entry-title">22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week</h1>        <div class="post-meta-share-wrapper">
            <div class="post-meta-detail">
                                    <span class="min-read-post-format">
                                                                            </span>
                <span class="entry-meta">
                                        
            <span class="item-metadata posts-author byline">
                    <i class="fa fa-pencil-square-o"></i>
            <a href="https://ironbladeonline.com/author/frosty-dirac/">
                Len Houle            </a>
        </span>
                                            </span>
                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                December 14, 2022            </span>
                        <span class="min-read">2 min read</span>            </div>
                    </div>
        
    </div>
                        </div>


                </div>

            </div>


            
        </header><!-- .entry-header -->

        <!-- end slider-section -->
            
    <div id="content" class="container-wrapper ">
    <div class="af-container-block-wrapper clearfix">
        <div id="primary" class="content-area ">
            <main id="main" class="site-main ">
                                    <article id="post-22938" class="post-22938 post type-post status-publish format-standard has-post-thumbnail hentry category-tech">

                        
                        
                                <div class="entry-content-wrap read-single">
                                                                        

        <div class="entry-content read-details">
            <div>
<p>The full lineup is as follows:</p>
<h2>PS Plus Extra</h2>
<h2>PS Plus Premium</h2>
<p>It&#8217;s been a great month this time around, as the PS Plus Extra has once again brought the goods.  Sony is leading WWE 2K22 as a major addition, and we were somewhat enamored of 2K Sports&#8217; slice of wrestling, describing it as a &#8220;back to form&#8221; in <a target="_blank" href="https://www.pushsquare.com/reviews/ps5/wwe-2k22" rel="noopener">We have a 7/10 review</a>.  It should be noted that WWE 2K22 will not be available until a later date on January 3, 2023.</p>
<p>Sony&#8217;s partnership with Ubisoft continues to pay off for members, too, with an offering of a trio of worthy Far Cry titles.  While we felt Far Cry 5 was a bit safe, we still give it a go <a target="_blank" href="https://www.pushsquare.com/reviews/ps4/far_cry_5" rel="noopener">7/10 in our review</a>Which is some great comfort food.  Speaking of which, Judgment, Yakuza Like a Dragon, and Yakuza 6: Song of Life should all help satiate Ryu Ga Gotoku Studio&#8217;s overhaul.  You can refer to our reviews below:</p>
<p>Elsewhere, the innovative puzzle game The Pedestrian is well worth your time, and it&#8217;s one we scored <a target="_blank" href="https://www.pushsquare.com/reviews/ps5/pedestrian" rel="noopener">8/10 in our review</a>Minor frustrations aside, The Pedestrian is a great puzzle platformer that stands out from the crowd. For those looking for a unique pick-up-and-play experience, it&#8217;s well worth the investment.  Both Middle-earth titles were award winners when they were first released.</p>
<p>Meanwhile, PS Plus Premium has a month better &#8211; although it still doesn&#8217;t look that great compared to PS Plus Extra.  Ninja Theory&#8217;s PS3 exclusive, the legendary Heavenly Sword, joins the cloud streaming ranks, along with two legacy titles: Ridge Racer 2 for PSP and Oddworld: Abe&#8217;s Exoddus for PS1.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://ironbladeonline.com/kingdom-hearts-4-star-wars-world-is-teased-for-the-first-time/" target="_blank" rel="dofollow" class="ub3a61b4ad999b6134826d59739e18878"><!-- INLINE RELATED POSTS 1/3 //--><style> .ub3a61b4ad999b6134826d59739e18878 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .ub3a61b4ad999b6134826d59739e18878:active, .ub3a61b4ad999b6134826d59739e18878:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .ub3a61b4ad999b6134826d59739e18878 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .ub3a61b4ad999b6134826d59739e18878 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .ub3a61b4ad999b6134826d59739e18878 .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .ub3a61b4ad999b6134826d59739e18878:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">Kingdom Hearts 4 Star Wars World is teased for the first time</span></div></a></div><p><!-- cache: html:pushsquare.com/ssl/playstation-plus/related-articles:142466 @ 2022-12-14T17:55:14+00:00 --></p>
<aside class="block object-related">
<div class="body">
<p>Pinball Heroes may be particularly curious for new PlayStation fans.  This was originally launched as a series of separate tables on the PSP, inspired by contemporary PS3 franchises such as <a target="_blank" href="https://www.pushsquare.com/games/pc/uncharted_legacy_of_thieves_collection" rel="noopener">Unknown</a> And the <a target="_blank" href="https://www.pushsquare.com/games/ps3/motorstorm" rel="noopener">MotorStorm</a>.  The layouts aren&#8217;t bad, and the game was eventually ported to the PS Vita as a full suite a few years later.  It might be worth checking it out.</p>
<p>So, what are your thoughts on this month&#8217;s PS Plus Extra and PS Plus Premium deals?  Remember that you can still get a subscription to <a target="_blank" href="https://www.pushsquare.com/news/2022/12/new-returning-ps-plus-members-can-save-p25usd30-before-xmas" rel="noopener">reduced fees</a> If you&#8217;re a new or expired member, so if you like what you see, there&#8217;s no better time to join.</p>
<p class="text source">[source <a target="_blank" class="external" title="External Link: https://blog.playstation.com/222/12/14/playstation-plus-game-catalog-lineup-for-december-far-cry-5-judgment-mortal-shell-and-more/" rel="noopener" href="https://blog.playstation.com/222/12/14/playstation-plus-game-catalog-lineup-for-december-far-cry-5-judgment-mortal-shell-and-more/">blog.playstation.com</a>]
<p><!-- cache: html:pushsquare.com/ssl/playstation-plus/related-info/d41d8cd98f00b204e9800998ecf8427e @ 2022-12-14T18:05:22+00:00 --></div>
<div class="related-content">
<div class="optional">
<section class="block author">
<div class="body">
<p class="avatar"></p>
<div class="text">
<p>A true PlayStation veteran, Sammy&#8217;s has covered the PS gaming world for years, with an impressive number of awards to prove it.  He also likes tennis games more than you.</p>
</div></div>
</section>
</div>
</div>
</aside>
</div>
<p><script type="aa7e5e9fc656e97e5f289bf3-text/javascript">dgpConsent.can('targeting',function () { !function(f,b,e,v,n,t,s) {if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init', '687986255298009'); fbq('track', 'PageView'); });</script></p>
<!--CusAds0-->
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100"  height="100" alt="" itemprop="image" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2021/08/c2d44d0d-0d36-4be6-9d2c-170da441572a.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2021/08/c2d44d0d-0d36-4be6-9d2c-170da441572a.jpg" width="100"  height="100" alt="" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://ironbladeonline.com/author/frosty-dirac/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Len Houle</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>&#8220;Hipster-friendly explorer. Award-winning coffee fanatic. Analyst. Problem solver. Troublemaker.&#8221;</p>
</div></div><div class="clearfix"></div></div></div>                            <div class="post-item-metadata entry-meta">
                                    </div>
                        
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://ironbladeonline.com/the-mega-man-battle-network-legacy-collection-launches-on-april-14-2023/" rel="prev"><span class="em-post-navigation">Previous</span> The Mega Man Battle Network Legacy Collection launches on April 14, 2023</a></div></div>
	</nav>                    </div><!-- .entry-content -->
                                </div>

                        <div class="aft-comment-related-wrap">
                            
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://ironbladeonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='22938' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1cf95fb8a6" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="85"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

                            
<div class="promotionspace enable-promotionspace">

        <div class="af-reated-posts grid-layout">
                            <h4 class="widget-title header-after1">
                            <span class="header-after">
                                More Stories                            </span>
                </h4>
                        <div class="af-container-row clearfix">
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mega-Man-Battle-Network-Legacy-Collection-launches-on-April-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mega-Man-Battle-Network-Legacy-Collection-launches-on-April-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mega-Man-Battle-Network-Legacy-Collection-launches-on-April-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">5 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/the-mega-man-battle-network-legacy-collection-launches-on-april-14-2023/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/the-mega-man-battle-network-legacy-collection-launches-on-april-14-2023/">The Mega Man Battle Network Legacy Collection launches on April 14, 2023</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/frosty-dirac/">
                            Len Houle                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/Fairy-Fencer-F-Refrain-Chord-is-coming-west-in-Spring-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/Fairy-Fencer-F-Refrain-Chord-is-coming-west-in-Spring-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/Fairy-Fencer-F-Refrain-Chord-is-coming-west-in-Spring-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/fairy-fencer-f-refrain-chord-is-coming-west-in-spring-2023-for-ps5-ps4-switch-and-pc/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/fairy-fencer-f-refrain-chord-is-coming-west-in-spring-2023-for-ps5-ps4-switch-and-pc/">Fairy Fencer F: Refrain Chord is coming west in Spring 2023 for PS5, PS4, Switch and PC</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/frosty-dirac/">
                            Len Houle                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/1670955527_World-of-Warcrafts-Trading-Post-is-bringing-back-cosmetics-you-720x475.png">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/1670955527_World-of-Warcrafts-Trading-Post-is-bringing-back-cosmetics-you-720x475.png"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/1670955527_World-of-Warcrafts-Trading-Post-is-bringing-back-cosmetics-you-720x475.png"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://ironbladeonline.com/world-of-warcrafts-trading-post-is-bringing-back-cosmetics-you-might-have-missed/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://ironbladeonline.com/world-of-warcrafts-trading-post-is-bringing-back-cosmetics-you-might-have-missed/">World of Warcraft&#8217;s Trading Post is bringing back cosmetics you might have missed</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 13, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/frosty-dirac/">
                            Len Houle                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                            </div>

    </div>
</div>


                        </div>


                    </article>
                
            </main><!-- #main -->
        </div><!-- #primary -->
        



<div id="secondary" class="sidebar-area aft-sticky-sidebar">
    <div class="theiaStickySidebar">
        <aside class="widget-area color-pad">
            <div id="nav_menu-2" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://ironbladeonline.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://ironbladeonline.com/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://ironbladeonline.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://ironbladeonline.com/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://ironbladeonline.com/science/">science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-535"><a href="https://ironbladeonline.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://ironbladeonline.com/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://ironbladeonline.com/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2988"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div></div><div id="nav_menu-3" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Pages</span></h2><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li id="menu-item-498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-498"><a href="https://ironbladeonline.com/">Home</a></li>
<li id="menu-item-2991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2991"><a href="https://ironbladeonline.com/about-us/">About Us</a></li>
<li id="menu-item-2990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2990"><a href="https://ironbladeonline.com/dmca/">DMCA</a></li>
<li id="menu-item-2989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2989"><a href="https://ironbladeonline.com/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-2992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2992"><a href="https://ironbladeonline.com/contact-form/">Contact Form</a></li>
</ul></div></div>        </aside>
    </div>
</div>    </div>


</div>

<div class="af-main-banner-latest-posts grid-layout">
    <div class="container-wrapper">
    <div class="af-container-block-wrapper pad-20">
            <div class="widget-title-section">
                                    <h4 class="widget-title header-after1">
                            <span class="header-after">
                                You may have missed                            </span>
                    </h4>
                
            </div>
            <div class="af-container-row clearfix">
                                            <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/Patty-Jenkins-breaks-the-silence-in-Wonder-Woman-3-720x450.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/Patty-Jenkins-breaks-the-silence-in-Wonder-Woman-3-720x450.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/Patty-Jenkins-breaks-the-silence-in-Wonder-Woman-3-720x450.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/patty-jenkins-breaks-the-silence-in-wonder-woman-3/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/entertainment/" alt="View all posts in entertainment"> 
                                 entertainment
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/patty-jenkins-breaks-the-silence-in-wonder-woman-3/">Patty Jenkins breaks the silence in Wonder Woman 3</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/muhammad/">
                            Roxanne Bacchus                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mars-rover-captures-the-first-sound-of-a-dust-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mars-rover-captures-the-first-sound-of-a-dust-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/The-Mars-rover-captures-the-first-sound-of-a-dust-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/the-mars-rover-captures-the-first-sound-of-a-dust-devil-on-the-red-planet/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/science/" alt="View all posts in science"> 
                                 science
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/the-mars-rover-captures-the-first-sound-of-a-dust-devil-on-the-red-planet/">The Mars rover captures the first sound of a dust devil on the Red Planet</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/vihaan/">
                            Cheryl Riley                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/Jets-Robert-Salih-Zach-Wilson-is-the-Lions-No-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/Jets-Robert-Salih-Zach-Wilson-is-the-Lions-No-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/Jets-Robert-Salih-Zach-Wilson-is-the-Lions-No-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">4 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/jets-robert-salih-zach-wilson-is-the-lions-no-2-qb/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/sport/" alt="View all posts in sport"> 
                                 sport
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/jets-robert-salih-zach-wilson-is-the-lions-no-2-qb/">Jets&#8217; Robert Salih &#8211; Zach Wilson is the Lions&#8217; No. 2 QB</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/reyansh/">
                            Joy Love                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-720x475.jpg"><noscript><img src="https://ironbladeonline.com/wp-content/uploads/2022/12/1671042099_22-new-PS5-and-PS4-games-coming-to-PS-Plus-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://ironbladeonline.com/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://ironbladeonline.com/22-new-ps5-and-ps4-games-coming-to-ps-plus-extra-and-premium-next-week/">22 new PS5 and PS4 games coming to PS Plus Extra and Premium next week</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    December 14, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://ironbladeonline.com/author/frosty-dirac/">
                            Len Houle                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                        </div>
    </div>
    </div>
</div>

<footer class="site-footer">
        
                <div class="site-info">
        <div class="container-wrapper">
            <div class="af-container-row">
                <div class="col-1 color-pad">
                                                                Copyright &copy; All rights reserved.                                                                                    <span class="sep"> | </span>
                        <a href="https://afthemes.com/products/newsever">Newsever</a> by AF themes.                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>













<script type='text/javascript' id='newsever-pagination-js-js-extra'>
/* <![CDATA[ */
var AFurl = {"nonce":"7cfcd184c6","ajaxurl":"https:\/\/ironbladeonline.com\/wp-admin\/admin-ajax.php","dir":"left"};
/* ]]> */
</script>




<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/ironbladeonline.com\/wp-json\/","fifu_nonce":"0364cfa6d7"};
/* ]]> */
</script>



<script src='https://stats.wp.com/e-202250.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'196518127',post:'22938',tz:'2',srv:'ironbladeonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '196518127', '22938' ]);
</script>
<script>window.lazyLoadOptions=[{elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}},{elements_selector:".rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,}];window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://ironbladeonline.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://ironbladeonline.com/wp-content/cache/min/1/7f8d948f79165941de19ad771884add4.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->